Discuz 解决您安装的不是正版应用安装程序无法继续执行

2016-8-9 21:00| 发布者: admin| 查看: 2359| 评论: 0

摘要: 这个错误提示对于使用Discuz建站的朋友来说,在安装主题,或者安装插件的时候出现的话肯定会很郁闷吧,毕竟辛辛苦苦找到的心仪的资源竟然不能使用,一定非常不甘心。这个提示,毫无疑问就是要您付费购买正版的应用了 ...

这个错误提示对于使用Discuz建站的朋友来说,在安装主题,或者安装插件的时候出现的话肯定会很郁闷吧,毕竟辛辛苦苦找到的心仪的资源竟然不能使用,一定非常不甘心。

这个提示,毫无疑问就是要您付费购买正版的应用了。那么我们是不是真的就必须购买正版的了呢?

中国人嘛,对于版权问题,大家都懂的~有盗版的绝对不用正版,利益所趋。其实出现这个提示,是因为新版的discuz增加了一个对模板或者插件版本的检测功能,我们只需要

找到这段检测,把它删掉或者注释掉就可以完美解决问题了。

解决方法:

找到文件/source/function/function_cloudaddons.php

打开function_cloudaddons.php,找到cloudaddons_validator方法,

删去或者注释掉cpmsg(‘cloudaddons_genuine_message’, ”, ‘error’, array(‘addonid’ => $addonid));这句代码,

这样就解决问题了。

1

惊呆

大哭

感动

晕倒

口水

刚表态过的朋友 (1 人)

分享到微博 收藏 邀请